--- Twisted-2.5.0/TwistedCore-2.5.0/setup.py	2006-12-22 23:02:47.000000000 -0600
+++ Twisted-2.5.0.new/TwistedCore-2.5.0/setup.py	2007-05-14 16:13:36.095282000 -0500
@@ -16,9 +16,8 @@
 from distutils.core import Extension
 
 if os.path.exists('twisted'):
-    sys.path.insert(0, '.') # eek! need this to import twisted. sorry.
-from twisted import copyright
-from twisted.python import dist, util
+    sys.path.insert(0, 'twisted/python') # eek! need this to import twisted. sorry.
+import dist
 
 def detectExtensions(builder):
     """
@@ -72,7 +71,7 @@
 setup_args = dict(
     # metadata
     name="Twisted",
-    version=copyright.version,
+    version="2.5.0",
     description="An asynchronous networking framework written in Python",
     author="Twisted Matrix Laboratories",
     author_email="twisted-python@twistedmatrix.com",
--- Twisted-2.5.0/TwistedWords-0.5.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedWords-0.5.0/setup.py	2007-05-14 16:24:39.860764750 -0500
@@ -1,7 +1,8 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
 
 try:
-    from twisted.python import dist
+    import dist
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedCore-2.5.0/twisted/python/dist.py	2006-10-01 14:16:04.000000000 -0500
+++ Twisted-2.5.0.new//TwistedCore-2.5.0/twisted/python/dist.py	2007-05-14 16:50:07.952264500 -0500
@@ -85,12 +85,25 @@
     "2.0.0".
     """
     if proj == 'core':
-        vfile = os.path.join(base, '_version.py')
+        return '2.5.0'
+    elif proj == 'words':
+        return '0.7.0'
+    elif proj == 'conch':
+        return '0.8.0'
+    elif proj == 'lore':
+        return '0.3.0'
+    elif proj == 'mail':
+        return '0.4.0'
+    elif proj == 'names':
+        return '0.4.0'
+    elif proj == 'news':
+        return '0.3.0'
+    elif proj == 'runner':
+        return '0.2.0'
+    elif proj == 'web':
+        return '0.7.0'
     else:
-        vfile = os.path.join(base, proj, '_version.py')
-    ns = {'__name__': 'Nothing to see here'}
-    execfile(vfile, ns)
-    return ns['version'].base()
+        return False
     
 
 # Names that are exluded from globbing results:
--- Twisted-2.5.0/TwistedConch-0.8.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new//TwistedConch-0.8.0/setup.py	2007-05-14 17:00:05.501609000 -0500
@@ -1,7 +1,8 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
 
 try:
-    from twisted.python import dist
+    import dist
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedLore-0.3.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedLore-0.3.0/setup.py	2007-05-14 17:17:25.374597000 -0500
@@ -1,7 +1,8 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
 
 try:
-    from twisted.python import dist
+    import dist
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedMail-0.4.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedMail-0.4.0/setup.py	2007-05-14 17:18:02.544920000 -0500
@@ -1,7 +1,10 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
+
 
 try:
-    from twisted.python import dist
+    import dist
+
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedNames-0.4.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedNames-0.4.0/setup.py	2007-05-14 17:18:37.707117500 -0500
@@ -1,7 +1,10 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
+
 
 try:
-    from twisted.python import dist
+    import dist
+
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedNews-0.3.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedNews-0.3.0/setup.py	2007-05-14 17:19:16.769558750 -0500
@@ -1,6 +1,9 @@
+import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
 
 try:
-    from twisted.python import dist
+    import dist
+
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedRunner-0.2.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedRunner-0.2.0/setup.py	2007-05-14 17:20:54.367658250 -0500
@@ -1,8 +1,11 @@
+import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
 
 from distutils.core import Extension
 
 try:
-    from twisted.python import dist
+    import dist
+
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "
--- Twisted-2.5.0/TwistedWeb-0.7.0/setup.py	2006-05-13 14:26:09.000000000 -0500
+++ Twisted-2.5.0.new/TwistedWeb-0.7.0/setup.py	2007-05-14 17:21:21.065326750 -0500
@@ -1,7 +1,10 @@
 import sys
+sys.path.append('../TwistedCore-2.5.0/twisted/python')
+
 
 try:
-    from twisted.python import dist
+    import dist
+
 except ImportError:
     raise SystemExit("twisted.python.dist module not found.  Make sure you "
                      "have installed the Twisted core package before "