--- a/sml/Makefile	2012-12-05 18:54:49.000000000 +0100
+++ b/sml/Makefile	2012-12-05 19:01:26.347952235 +0100
@@ -1,4 +1,4 @@
-UNAME := $(shell uname)
+UNAME ?= $(shell uname)
 CFLAGS += -I./include/ -fPIC -fno-stack-protector -g -Wall
 
 # Available Flags: