Index: lighttpd-1.4.16/configure
===================================================================
--- lighttpd-1.4.16.orig/configure	2007-07-26 11:58:37.000000000 +0200
+++ lighttpd-1.4.16/configure	2007-07-26 11:58:37.000000000 +0200
@@ -23844,7 +23844,7 @@
 { echo "$as_me:$LINENO: result: $WITH_PCRE" >&5
 echo "${ECHO_T}$WITH_PCRE" >&6; }
 
-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+if test "$WITH_PCRE" != "no"; then
   # Extract the first word of "pcre-config", so it can be a program name with args.
 set dummy pcre-config; ac_word=$2
 { echo "$as_me:$LINENO: checking for $ac_word" >&5
Index: lighttpd-1.4.16/configure.in
===================================================================
--- lighttpd-1.4.16.orig/configure.in	2007-07-26 11:58:37.000000000 +0200
+++ lighttpd-1.4.16/configure.in	2007-07-26 11:58:37.000000000 +0200
@@ -250,7 +250,7 @@
     [WITH_PCRE=$withval],[WITH_PCRE=yes])
 AC_MSG_RESULT([$WITH_PCRE])
 
-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+if test "$WITH_PCRE" != "no"; then
   AC_PATH_PROG(PCRECONFIG, pcre-config)
 
   if test x"$PCRECONFIG" != x; then