diff -ru seeks-0.3.3/src/Makefile.am seeks-0.3.3-new/src/Makefile.am
--- seeks-0.3.3/src/Makefile.am	2011-04-30 10:16:57.000000000 +0200
+++ seeks-0.3.3-new/src/Makefile.am	2011-05-27 10:56:09.648313435 +0200
@@ -57,12 +57,12 @@
 LDADD += -lseeksuserdb -lseeksuserdbfix
 endif
 endif
-LDADD += -lpcre -lpcreposix -lseekslsh -lseeksdht -lrmd160 -lpthread -lz @CURL_LDADD@
+LDADD += -lpcre -lpcreposix -lseekslsh -lseeksdht -lrmd160 -lpthread -lz -liconv @CURL_LDADD@
 if !HAVE_BSD
 LDADD += -ldl
 endif
 
-SUBDIRS=utils proxy lsh dht plugins proxy/tests lsh/tests .
+SUBDIRS=utils proxy lsh dht plugins .
 
 configdir=$(sysconfdir)/seeks
 dist_config_DATA=config \
diff -rU5 seeks-0.3.3/src/plugins/websearch/Makefile.am seeks-0.3.3-new/src/plugins/websearch/Makefile.am
--- seeks-0.3.3/src/plugins/websearch/Makefile.am	2011-04-30 10:16:57.000000000 +0200
+++ seeks-0.3.3-new/src/plugins/websearch/Makefile.am	2011-05-24 00:42:34.836033228 +0200
@@ -42,11 +42,11 @@
 
 if USE_PERL
 libseekswebsearchplugin_la_CXXFLAGS += `perl -MExtUtils::Embed -e ccopts`
 endif
 
-SUBDIRS=. tests
+SUBDIRS=. 
 
 websearchconfigdir=$(sysconfdir)/seeks
 dist_websearchconfig_DATA=websearch-config
 
 nobase_dist_websearchplugindata_DATA= \