--- a/configure
+++ b/configure
@@ -24315,8 +24315,7 @@ if test "$cross_compiling" = yes; then
   { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
 See \`config.log' for more details." >&5
 echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
-   { (exit 1); exit 1; }; }
+See \`config.log' for more details." >&2;} }
 else
   cat >conftest.$ac_ext <<_ACEOF
 /* confdefs.h.  */
--- a/configure.in
+++ b/configure.in
@@ -489,29 +489,6 @@ AC_ARG_ENABLE([file-security],
 	fi], [])
 
 
-AC_TRY_RUN([
-	#include <stdio.h>
-	
-	struct packstruct {
-		unsigned char t0       :5;
-		unsigned char t1       :5;
-		unsigned char t2       :5;
-		unsigned char t3       :5;
-		unsigned char t4       :4;
-	} __attribute__ ((packed));
-	
-	int
-	main(int argc, char ** argv)
-	{
-	if(sizeof(struct packstruct) != 3)
-	return(1);
-	else
-	return(0);
-	}
-	],[],[AC_DEFINE(HAVE_PRAGMA_PACK,[1],[Define to 1 if you need to use #pragma pack instead of __attribute__ ((packed))])]
-)
-
-
 dnl Generate files for build
 AC_CONFIG_FILES([Makefile
 		doc/Makefile