diff -u --recursive vips-7.28.9-vanilla/configure.in vips-7.28.9/configure.in
--- vips-7.28.9-vanilla/configure.in	2012-07-14 22:35:08.209029299 -0500
+++ vips-7.28.9/configure.in	2012-07-14 22:36:25.634927858 -0500
@@ -182,7 +182,6 @@
 AC_PROG_AWK
 AC_PROG_CC
 AC_PROG_CC_STDC
-AC_PROG_CXX
 AC_C_CONST
 AC_C_RESTRICT
 AC_PROG_RANLIB
@@ -190,45 +189,6 @@
 AC_PROG_LN_S
 AM_WITH_DMALLOC
 
-# vips_PROG_CXX_WORKS
-# Check whether the C++ compiler works.
-AC_DEFUN([vips_PROG_CXX_WORKS],
-  [AC_REQUIRE([AC_PROG_CXX])dnl
-   AC_CACHE_CHECK([whether the C++ compiler works],
-   [vips_cv_prog_cxx_works],
-   [AC_LANG_PUSH([C++])
-    AC_LINK_IFELSE([AC_LANG_PROGRAM([], [])],
-                   [vips_cv_prog_cxx_works=yes],
-                   [vips_cv_prog_cxx_works=no])
-    AC_LANG_POP([C++])])
-])
-
-# option to build without C++
-# handy for some embedded applications
-# also, including C++ source causes link problems on some
-# platforms, so have an option to disable it
-AC_ARG_ENABLE(cxx, 
-  AS_HELP_STRING([--enable-cxx], [build C++ components (default: test)]))
-
-if test x"$enable_cxx" != x"no"; then
-  vips_PROG_CXX_WORKS
-  if test x"$vips_cv_prog_cxx_works" = x"yes"; then 
-    AC_DEFINE(ENABLE_CXX,1,[build C++ components])
-    AM_CONDITIONAL(ENABLE_CXX, true)
-    # need -lstdc++ for (eg.) the C++ format loaders
-    # this gets added to vips-7.xx.pc to help mingw and friends link programs
-    # using libvips
-    VIPS_CXX_LIBS="-lstdc++"
-    enable_cxx=yes
-  fi
-fi
-
-if test x"$enable_cxx" != x"yes"; then
-  AM_CONDITIONAL(ENABLE_CXX, false)
-  VIPS_CXX_LIBS=""
-  enable_cxx=no
-fi
-
 # we need a fully expanded version of $libdir
 # without this we get something like
 #    define VIPS_LIBDIR ${exec_prefix}/lib
@@ -681,7 +641,6 @@
 AC_SUBST(VIPS_CFLAGS)
 AC_SUBST(VIPS_INCLUDES)
 AC_SUBST(VIPS_LIBS)
-AC_SUBST(VIPS_CXX_LIBS)
 AC_SUBST(PACKAGES_USED)
 
 # you'd think we could have 
@@ -689,14 +648,12 @@
 # in AC_OUTPUT, but that seems to break for some combinations of sh/m4
 AC_OUTPUT([
 	vips-7.28.pc
-	vipsCC-7.28.pc
 	Makefile 
 	libvips/include/vips/version.h 
 	libvips/include/Makefile 
 	libvips/include/vips/Makefile 
 	libvips/Makefile 
 	libvips/arithmetic/Makefile 
-	libvips/cimg/Makefile 
 	libvips/colour/Makefile 
 	libvips/conversion/Makefile 
 	libvips/convolution/Makefile 
@@ -711,9 +668,6 @@
 	libvips/other/Makefile 
 	libvips/resample/Makefile 
 	libvips/video/Makefile 
-	libvipsCC/include/Makefile 
-	libvipsCC/include/vips/Makefile 
-	libvipsCC/Makefile 
 	tools/Makefile 
 	tools/batch_crop 
 	tools/batch_image_convert 
@@ -721,7 +675,6 @@
 	tools/light_correct 
 	tools/shrink_width 
 	swig/Makefile 
-	swig/vipsCC/Makefile 
 	swig/python/setup.py 
 	man/Makefile
 	doc/Makefile
diff -u --recursive vips-7.28.9-vanilla/libvips/Makefile.am vips-7.28.9/libvips/Makefile.am
--- vips-7.28.9-vanilla/libvips/Makefile.am	2012-07-14 22:35:08.206029420 -0500
+++ vips-7.28.9/libvips/Makefile.am	2012-07-14 22:37:24.446571912 -0500
@@ -1,14 +1,4 @@
 # only build in the cimg dir if C++ is enabled
-if ENABLE_CXX
-C_COMPILE_DIR = cimg
-C_DIST_DIR =
-C_LIB = cimg/libcimg.la
-else
-C_COMPILE_DIR =
-C_DIST_DIR = cimg
-C_LIB = 
-endif
-
 SUBDIRS = \
 	include \
 	foreign \
@@ -18,7 +8,6 @@
 	conversion \
 	deprecated \
 	convolution \
-	$(C_COMPILE_DIR) \
 	freq_filt \
 	histograms_lut \
 	inplace \
@@ -34,14 +23,6 @@
 # empty means default to C linking
 libvips_la_SOURCES = 
 
-# if we have C++ components enabled, make sure we link the top-level with c++
-#
-# sadly the if/endif isn't enough to stop automake detecting a c++ link even
-# when c++ is disabled ... comment out this line if you have linking problems
-if ENABLE_CXX
-nodist_EXTRA_libvips_la_SOURCES = cimg/dummy2.cc
-endif
-
 # DLLs need dependant libs there too ... put @VIPS_LIBS@ at the end
 libvips_la_LIBADD = \
 	resample/libresample.la \
@@ -50,7 +31,6 @@
 	conversion/libconversion.la \
 	convolution/libconvolution.la \
 	deprecated/libdeprecated.la \
-	$(C_LIB) \
 	foreign/libforeign.la \
 	freq_filt/libfreq_filt.la \
 	histograms_lut/libhistograms_lut.la \
@@ -62,17 +42,10 @@
 	video/libvideo.la \
 	@VIPS_LIBS@
 
-if ENABLE_CXX
-libvips_la_LIBADD += @VIPS_CXX_LIBS@
-endif
-
 libvips_la_LDFLAGS = \
 	-no-undefined \
 	-version-info @LIBRARY_CURRENT@:@LIBRARY_REVISION@:@LIBRARY_AGE@ 
 
-EXTRA_DIST = \
-	$(C_DIST_DIR)
-
 CLEANFILES = 
 
 -include $(INTROSPECTION_MAKEFILE)
diff -u --recursive vips-7.28.9-vanilla/libvips/resample/Makefile.am vips-7.28.9/libvips/resample/Makefile.am
--- vips-7.28.9-vanilla/libvips/resample/Makefile.am	2012-07-14 22:35:08.191030020 -0500
+++ vips-7.28.9/libvips/resample/Makefile.am	2012-07-14 22:37:49.470569578 -0500
@@ -2,22 +2,6 @@
 # you'd think we could just define a couple of variables, but that seems to
 # confuse libtool and make it link the library with g++
 # instead, have two completely different paths
-if ENABLE_CXX
-
-libresample_la_SOURCES = \
-	im_affine.c \
-	interpolate.c \
-	im_shrink.c \
-	im_rightshift_size.c \
-	transform.c \
-	resample_dispatch.c \
-	bicubic.cpp \
-	lbb.cpp \
-	nohalo.cpp \
-	vsqbs.cpp \
-	templates.h 
-
-else
 
 libresample_la_SOURCES = \
 	im_affine.c \
@@ -27,15 +11,6 @@
 	transform.c \
 	resample_dispatch.c 
 
-EXTRA_DIST = \
-	bicubic.cpp \
-	lbb.cpp \
-	nohalo.cpp \
-	vsqbs.cpp \
-	templates.h 
-
-endif
-
 noinst_LTLIBRARIES = libresample.la
 
 INCLUDES = -I${top_srcdir}/libvips/include @VIPS_CFLAGS@ @VIPS_INCLUDES@ 
diff -u --recursive vips-7.28.9-vanilla/Makefile.am vips-7.28.9/Makefile.am
--- vips-7.28.9-vanilla/Makefile.am	2012-07-14 22:35:08.220028859 -0500
+++ vips-7.28.9/Makefile.am	2012-07-14 22:38:43.217417048 -0500
@@ -1,43 +1,17 @@
-
-# turn off libvipsCC if C++ is disabled
-if ENABLE_CXX
-C_COMPILE_DIR = libvipsCC
-C_DIST_DIR =
-C_PKGCONFIG = vipsCC-7.${VIPS_MINOR_VERSION}.pc
-
-# turn on Python if we can (requires C++)
-if HAVE_PYTHON
-P_COMPILE_DIR = swig
-P_DIST_DIR =
-endif
-
-else
-C_COMPILE_DIR =
-C_DIST_DIR = libvipsCC 
-C_PKGCONFIG =
-P_COMPILE_DIR =
-P_DIST_DIR = swig
-endif
-
 SUBDIRS = \
 	libvips \
 	tools \
 	po \
 	man \
-	doc \
-	$(C_COMPILE_DIR) \
-	$(P_COMPILE_DIR) 
+	doc
 
 EXTRA_DIST = \
 	m4 \
 	benchmark \
 	bootstrap.sh \
 	vips-7.${VIPS_MINOR_VERSION}.pc.in \
-	vipsCC-7.${VIPS_MINOR_VERSION}.pc.in \
 	acinclude.m4 \
-	depcomp \
-	$(C_DIST_DIR) \
-	$(P_DIST_DIR)
+	depcomp
 
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = vips-7.${VIPS_MINOR_VERSION}.pc $(C_PKGCONFIG)
diff -u --recursive vips-7.28.9-vanilla/tools/Makefile.am vips-7.28.9/tools/Makefile.am
--- vips-7.28.9-vanilla/tools/Makefile.am	2012-07-14 22:35:08.221028819 -0500
+++ vips-7.28.9/tools/Makefile.am	2012-07-14 22:40:51.397283833 -0500
@@ -16,9 +16,6 @@
 INCLUDES = -I${top_srcdir}/libvips/include @VIPS_CFLAGS@ @VIPS_INCLUDES@
 AM_LDFLAGS = @LDFLAGS@ 
 LDADD = @VIPS_CFLAGS@ ${top_builddir}/libvips/libvips.la @VIPS_LIBS@
-if ENABLE_CXX
-LDADD += @VIPS_CXX_LIBS@
-endif
 
 bin_SCRIPTS = \
 	light_correct \
diff -u --recursive vips-7.28.9-vanilla/vips-7.28.pc.in vips-7.28.9/vips-7.28.pc.in
--- vips-7.28.9-vanilla/vips-7.28.pc.in	2012-07-14 22:35:08.208029340 -0500
+++ vips-7.28.9/vips-7.28.pc.in	2012-07-14 22:41:03.591795535 -0500
@@ -7,5 +7,5 @@
 Description: Image processing library
 Version: @VERSION@
 Requires: @PACKAGES_USED@
-Libs: -L${libdir} -lvips @VIPS_LIBS@ @VIPS_CXX_LIBS@
+Libs: -L${libdir} -lvips @VIPS_LIBS@
 Cflags: -I${includedir}