Index: postgresql-8.3.0/src/port/Makefile
===================================================================
--- postgresql-8.3.0.orig/src/port/Makefile	2008-02-06 16:27:48.000000000 -0600
+++ postgresql-8.3.0/src/port/Makefile	2008-02-06 16:28:18.000000000 -0600
@@ -49,6 +49,7 @@
 
 libpgport.a: $(OBJS)
 	$(AR) $(AROPT) $@ $^
+	$(RANLIB) libpgport.a
 
 # thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
 thread.o: thread.c