95e89c8d4f
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22237 3c298f89-4303-0410-b956-a3cf2f4a3e73
30 lines
1.3 KiB
Diff
30 lines
1.3 KiB
Diff
--- a/codecs/gsm/Makefile
|
|
+++ b/codecs/gsm/Makefile
|
|
@@ -38,7 +38,7 @@ WAV49 = -DWAV49
|
|
######### probably require gcc.
|
|
|
|
ifeq (, $(findstring $(OSARCH) , Darwin SunOS ))
|
|
-ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb hppa2.0 ppc powerpc ppc64 ia64 s390 bfin mipsel mips))
|
|
+ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb avr32 hppa2.0 ppc powerpc ppc64 ia64 s390 bfin mipsel mips))
|
|
ifeq (, $(findstring $(shell uname -m) , ppc ppc64 alpha armv4l s390 ))
|
|
OPTIMIZE+=-march=$(PROC)
|
|
endif
|
|
@@ -209,7 +209,7 @@ GSM_SOURCES = $(SRC)/add.c \
|
|
# XXX should merge with GSM_OBJECTS
|
|
ifeq ($(OSARCH),linux-gnu)
|
|
ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc s390 ))
|
|
-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel mips ))
|
|
+ifeq (,$(findstring $(PROC) , arm armv5b armeb avr32 powerpc ia64 s390 bfin mipsel mips ))
|
|
GSM_SOURCES+= $(SRC)/k6opt.s
|
|
endif
|
|
endif
|
|
@@ -261,7 +261,7 @@ GSM_OBJECTS = $(SRC)/add.o \
|
|
|
|
ifeq ($(OSARCH),linux-gnu)
|
|
ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc ))
|
|
-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel mips ))
|
|
+ifeq (,$(findstring $(PROC) , arm armv5b armeb avr32 powerpc ia64 bfin mipsel mips ))
|
|
GSM_OBJECTS+= $(SRC)/k6opt.o
|
|
endif
|
|
endif
|