packages/lang/python-ecore/patches/000-prevent-using-setuptools.patch
mirko 02f2b8ced6 update efl stuff to git revision 38564
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14029 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-13 22:06:38 +00:00

25 lines
887 B
Diff

diff -ruN python-ecore-r38564.orig/setup.py python-ecore-r38564/setup.py
--- python-ecore-r38564.orig/setup.py 2009-01-13 10:27:34.000000000 +0100
+++ python-ecore-r38564/setup.py 2009-01-13 11:08:26.000000000 +0100
@@ -1,10 +1,7 @@
import sys
import os
-from ez_setup import use_setuptools
-use_setuptools('0.6c9')
-
-from setuptools import setup, find_packages, Extension
+from distutils.core import setup, Extension
import subprocess
import shlex
@@ -143,7 +140,7 @@
long_description=long_description,
keywords='wrapper binding enlightenment abstraction event ecore',
classifiers=trove_classifiers,
- packages=find_packages(),
+ packages=['ecore', 'ecore.x', 'ecore.evas', 'ecore.imf'],
install_requires=['python-evas>=0.3.1'],
setup_requires=['python-evas>=0.3.1'],
ext_modules=[ecoremodule, ecoreevasmodule, ecorexmodule,