packages/lang/python/patches/070-dont-clean-ipkg-install.patch
mb 469dd1b2a8 python: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22968 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-09-07 11:16:04 +00:00

22 lines
865 B
Diff

---
Makefile.pre.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- Python-2.6.4.orig/Makefile.pre.in
+++ Python-2.6.4/Makefile.pre.in
@@ -1118,11 +1118,11 @@ TAGS::
# Sanitation targets -- clean leaves libraries, executables and tags
# files, which clobber removes as well
pycremoval:
- find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
+ find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
clean: pycremoval
- find . -name '*.o' -exec rm -f {} ';'
- find . -name '*.s[ol]' -exec rm -f {} ';'
+ find . ! -path './ipkg-install/*' -name '*.o' -exec rm -f {} ';'
+ find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
-rm -f Lib/lib2to3/*Grammar*.pickle