a456db34e4
Get rid of the virtual python-core package and instead python depends on python-mini and provides files missing in python-mini for a full featured python installation. Thus also update the dependencies of various python packages. git-svn-id: svn://svn.openwrt.org/openwrt/packages@14760 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
1.2 KiB
Diff
28 lines
1.2 KiB
Diff
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index a341e63..e949653 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -879,22 +879,6 @@ libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
|
|
done; \
|
|
done
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- ./$(BUILDPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST) -f \
|
|
- -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
|
|
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- ./$(BUILDPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST) -f \
|
|
- -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
|
|
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- ./$(BUILDPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST)/site-packages -f \
|
|
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- ./$(BUILDPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST)/site-packages -f \
|
|
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
./$(BUILDPYTHON) -Wi -t -c "import lib2to3.pygram, lib2to3.patcomp;lib2to3.patcomp.PatternCompiler()"
|
|
|