a456db34e4
Get rid of the virtual python-core package and instead python depends on python-mini and provides files missing in python-mini for a full featured python installation. Thus also update the dependencies of various python packages. git-svn-id: svn://svn.openwrt.org/openwrt/packages@14760 3c298f89-4303-0410-b956-a3cf2f4a3e73
41 lines
1.6 KiB
Diff
41 lines
1.6 KiB
Diff
diff --git a/setup.py b/setup.py
|
|
index 32e1af8..f7f190f 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
|
|
return sys.platform
|
|
|
|
def detect_modules(self):
|
|
- # Ensure that /usr/local is always used
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|
|
@@ -347,11 +344,6 @@ class PyBuildExt(build_ext):
|
|
for directory in reversed(options.dirs):
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
- if os.path.normpath(sys.prefix) != '/usr':
|
|
- add_dir_to_list(self.compiler.library_dirs,
|
|
- sysconfig.get_config_var("LIBDIR"))
|
|
- add_dir_to_list(self.compiler.include_dirs,
|
|
- sysconfig.get_config_var("INCLUDEDIR"))
|
|
|
|
try:
|
|
have_unicode = unicode
|
|
@@ -361,11 +353,8 @@ class PyBuildExt(build_ext):
|
|
# lib_dirs and inc_dirs are used to search for files;
|
|
# if a file is found in one of those directories, it can
|
|
# be assumed that no additional -I,-L directives are needed.
|
|
- lib_dirs = self.compiler.library_dirs + [
|
|
- '/lib64', '/usr/lib64',
|
|
- '/lib', '/usr/lib',
|
|
- ]
|
|
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
|
|
+ lib_dirs = self.compiler.library_dirs
|
|
+ inc_dirs = self.compiler.include_dirs
|
|
exts = []
|
|
missing = []
|
|
|