6b657b6639
libdbi's configure.in is hardcoding CFLAGS and does not allow the configure script environment to override those. Remove the hardcoded CFLAGS as they are completely bogus and do not allow for any configuration. Fixes the build on ARM VFP toolchains. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39797 3c298f89-4303-0410-b956-a3cf2f4a3e73
46 lines
1.7 KiB
Diff
46 lines
1.7 KiB
Diff
--- libdbi-0.8.3/configure.in 2014-03-06 14:04:14.708630767 -0800
|
|
+++ libdbi-0.8.3/configure.in 2014-03-06 14:04:53.229096958 -0800
|
|
@@ -32,42 +32,6 @@
|
|
dnl Set some general compile options
|
|
dnl ====================================
|
|
|
|
-if test -z "$GCC"; then
|
|
- case $host in
|
|
- *-*-irix*)
|
|
- if test -z "$CC"; then
|
|
- CC=cc
|
|
- fi
|
|
- DEBUG="-g -signed"
|
|
- CFLAGS="-O2 -w -signed"
|
|
- PROFILE="-p -g3 -O2 -signed" ;;
|
|
- sparc-sun-solaris*)
|
|
- DEBUG="-v -g"
|
|
- CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
|
|
- PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
|
|
- *)
|
|
- DEBUG="-g"
|
|
- CFLAGS="-O"
|
|
- PROFILE="-g -p" ;;
|
|
- esac
|
|
-else
|
|
-
|
|
- case $host in
|
|
- *-*-linux*)
|
|
- DEBUG="-g -Wall -D_REENTRANT -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
|
|
- CFLAGS="-O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99"
|
|
- PROFILE="-pg -g -O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99";;
|
|
- sparc-sun-*)
|
|
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
|
|
- CFLAGS="-O20 -ffast-math -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
|
|
- PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99" ;;
|
|
- *)
|
|
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
|
|
- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
|
|
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char -std=gnu99" ;;
|
|
- esac
|
|
-fi
|
|
-
|
|
AC_SUBST(DEBUG)
|
|
AC_SUBST(PROFILE)
|
|
|