packages/net/snort/patches/101-PCAP.patch
florian 0c4ed19f02 [package] Snort: update to 2.9.2.2
I've managed to update Snort to version 2.9.2.2. I did not want to split this patch even if it has so many deltas - there are many deletions of unused patches. Also there is a configuration file that has almost the same functionality as the 2.8.4.1 one. The reason I've not written a patch for update to 2.9.3 is to preserve compatibility with snortsam which has not patch for 2.9.3 yet.

If this patch becomes accepted then patch http://patchwork.openwrt.org/patch/2381/ becomes obsolete, because it depends on 2.8.4.1. Next patch (3/3) introduces support for Snortsam package (Snortsam is snort version independent, just needs snort to be patched with proper patch).

Signed-off-by: Jiri Slachta <jiri@slachta.eu>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@33169 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-08-13 14:08:40 +00:00

32 lines
693 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -401,16 +401,18 @@ if test "x$LPCAP" = "xno"; then
fi
AC_MSG_CHECKING([for pcap_lex_destroy])
-AC_RUN_IFELSE(
-[AC_LANG_PROGRAM(
-[[
-#include <pcap.h>
-]],
-[[
- pcap_lex_destroy();
-]])],
-[have_pcap_lex_destroy="yes"],
-[have_pcap_lex_destroy="no"])
+have_pcap_lex_destroy="yes"
+#AC_RUN_IFELSE(
+#[AC_LANG_PROGRAM(
+#[[
+##include <pcap.h>
+#]],
+#[[
+# pcap_lex_destroy();
+#]])],
+#[have_pcap_lex_destroy="yes"],
+#[have_pcap_lex_destroy="no"])
+
AC_MSG_RESULT($have_pcap_lex_destroy)
if test "x$have_pcap_lex_destroy" = "xyes"; then
AC_DEFINE([HAVE_PCAP_LEX_DESTROY],[1],[Can cleanup lex buffer stack created by pcap bpf filter])