packages/net/samba3/patches/140-no_mmap.patch
blogic 2b63fb6a50 adds samba3
- compiles at ~1MB (or ~1,3MB if log files are enabled)
- patches to make samba3 small come from avm gpl releases
- added patches to match owrt dir layout
- rewritten smbpasswd to be endian safe and small
- printing is not yet tested
- disabled mmap as this breaks and oopses when running on jffs2



git-svn-id: svn://svn.openwrt.org/openwrt/packages@12278 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-08-11 14:00:58 +00:00

28 lines
937 B
Diff

Index: samba-3.0.24/source/include/config.h
===================================================================
--- samba-3.0.24.orig/source/include/config.h 2008-08-08 17:43:08.000000000 +0200
+++ samba-3.0.24/source/include/config.h 2008-08-08 17:44:02.000000000 +0200
@@ -821,7 +821,7 @@
#define HAVE_MKTIME 1
/* Whether mmap works */
-#define HAVE_MMAP 1
+/* #define HAVE_MMAP 1 */
/* Define to 1 if you have the <mntent.h> header file. */
#define HAVE_MNTENT_H 1
Index: samba-3.0.24/source/tdb/Makefile
===================================================================
--- samba-3.0.24.orig/source/tdb/Makefile 2008-08-08 17:42:47.000000000 +0200
+++ samba-3.0.24/source/tdb/Makefile 2008-08-08 17:44:15.000000000 +0200
@@ -2,7 +2,8 @@
# Makefile for tdb directory
#
-CFLAGS = -DSTANDALONE -DTDB_DEBUG -g -DHAVE_MMAP=1
+CFLAGS = -DSTANDALONE -DTDB_DEBUG -g
+#-DHAVE_MMAP=1
CC = gcc
ADMINPROGS = tdbdump tdbbackup