3475b58d04
This patch also fixes the ping6 linking issues with uClibc by disabling the libresolv-based stuff (the "-N nodeinfo-option" feature). Signed-off-by: Luis Alberto Dallos Roa <luis.dallos at gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@26994 3c298f89-4303-0410-b956-a3cf2f4a3e73
15 lines
398 B
Diff
15 lines
398 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -18,7 +18,10 @@ CFLAGS=$(CCOPT) $(GLIBCFIX) $(DEFINES)
|
|
|
|
IPV4_TARGETS=tracepath ping clockdiff arping tftpd
|
|
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
|
-TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
|
+TARGETS=$(IPV4_TARGETS)
|
|
+ifeq ($(CONFIG_IPV6),y)
|
|
+ TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
|
+endif
|
|
|
|
LASTTAG:=`git describe HEAD | sed -e 's/-.*//'`
|
|
TAG:=`date +s%Y%m%d`
|