packages/net/freeswitch/patches/000-build-openwrt_rules.mk.patch
mazilo ba29e584e0 Remove all old config XML files and update to copy config files on-the-fly directly from FS source tree during installation process.
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35465 3c298f89-4303-0410-b956-a3cf2f4a3e73
2013-02-02 17:15:23 +00:00

11 lines
384 B
Diff

--- /dev/null
+++ b/build/openwrt_rules.mk
@@ -0,0 +1,7 @@
+OPENWRT_DIR=$(shell (cd $(BASE)/../../..;pwd))
+STAGING_PREFIX=$(OPENWRT_DIR)/staging_dir/host
+STAGING_DIR=$(OPENWRT_DIR)/staging_dir/$(shell (cd $(BASE)/..;basename `pwd`))
+ARCH="$(shell grep CONFIG_ARCH $(OPENWRT_DIR)/.config|cut -d= -d'"' -f2)"
+GNU_TARGET_NAME=$(ARCH)-openwrt-linux
+
+include $(OPENWRT_DIR)/rules.mk