packages/lang/pyevent/patches/000-libenevt_path_from_env.patch
nico b94f02fe5f massive python changes:
* move all python packages to lang section
 * add a python-package.mk rules file sourced by all python packages for PyPackage/* defs
 * introduce a new way of specifying files to be packaged (experimental)
 * add missing svn:properties


git-svn-id: svn://svn.openwrt.org/openwrt/packages@8639 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-09-06 02:52:35 +00:00

21 lines
812 B
Diff

diff -ruN pyevent-0.3.pris/setup.py pyevent-0.3/setup.py
--- pyevent-0.3.pris/setup.py 2005-09-11 22:44:04.000000000 -0500
+++ pyevent-0.3/setup.py 2007-04-23 11:17:14.500323500 -0500
@@ -5,9 +5,13 @@
from distutils.core import setup, Extension
import glob, os, sys
-if glob.glob('/usr/lib/libevent.*'):
- print 'found system libevent for', sys.platform
- event = Extension(name='event',
+# Where to find libevent
+libevent_location = os.environ.get('LIBEVENT_HOME')
+
+if libevent_location != None:
+ if glob.glob('%s/libevent.*' % (libevent_location,)):
+ print 'found system libevent for', sys.platform
+ event = Extension(name='event',
sources=[ 'event.c' ],
libraries=[ 'event' ])
elif glob.glob('%s/lib/libevent.*' % sys.prefix):