packages/ipv6/send/patches/004-always_link_with_ncurses.patch
nico 2de67b2eab refresh patches before applying upcoming fix
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13966 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-10 23:53:44 +00:00

27 lines
589 B
Diff

We should always link with libncurses. This is not noticeable
when building the debian packages because we install libncurses5
runtime library as a dependency.
--- a/cgatool/Makefile
+++ b/cgatool/Makefile
@@ -17,7 +17,7 @@ LDLIBS= $(DEPLIBS)
LDFLAGS= -L../libs/.libs
endif
-LDLIBS += -lcrypto
+LDLIBS += -lcrypto -lncurses
ifeq ($(USE_THREADS),y)
LDLIBS += -lpthread
--- a/sendd/Makefile
+++ b/sendd/Makefile
@@ -28,7 +28,7 @@ LDLIBS= $(DEPLIBS)
LDFLAGS= -L../libs/.libs
endif
-LDLIBS += -lcrypto
+LDLIBS += -lcrypto -lncurses
LDLIBS += $(OSLIBS)
ifeq ($(USE_THREADS),y)