0c4ed19f02
I've managed to update Snort to version 2.9.2.2. I did not want to split this patch even if it has so many deltas - there are many deletions of unused patches. Also there is a configuration file that has almost the same functionality as the 2.8.4.1 one. The reason I've not written a patch for update to 2.9.3 is to preserve compatibility with snortsam which has not patch for 2.9.3 yet. If this patch becomes accepted then patch http://patchwork.openwrt.org/patch/2381/ becomes obsolete, because it depends on 2.8.4.1. Next patch (3/3) introduces support for Snortsam package (Snortsam is snort version independent, just needs snort to be patched with proper patch). Signed-off-by: Jiri Slachta <jiri@slachta.eu> git-svn-id: svn://svn.openwrt.org/openwrt/packages@33169 3c298f89-4303-0410-b956-a3cf2f4a3e73
67 lines
1.7 KiB
Diff
67 lines
1.7 KiB
Diff
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -1128,63 +1128,6 @@ if test "x$with_mysql" != "xno"; then
|
|
fi
|
|
fi
|
|
|
|
- AC_MSG_CHECKING([for mysql default client reconnect])
|
|
-
|
|
- AC_RUN_IFELSE(
|
|
- [AC_LANG_PROGRAM(
|
|
- [[
|
|
- #include <mysql.h>
|
|
- ]],
|
|
- [[
|
|
- if (mysql_get_client_version() < 50003)
|
|
- return 1;
|
|
- ]])],
|
|
- [mysql_default_reconnect="no"],
|
|
- [mysql_default_reconnect="yes"])
|
|
-
|
|
- AC_MSG_RESULT($mysql_default_reconnect)
|
|
-
|
|
- if test "x$mysql_default_reconnect" = "xno"; then
|
|
- AC_MSG_CHECKING([for mysql reconnect option])
|
|
-
|
|
- AC_RUN_IFELSE(
|
|
- [AC_LANG_PROGRAM(
|
|
- [[
|
|
- #include <mysql.h>
|
|
- ]],
|
|
- [[
|
|
- if (mysql_get_client_version() < 50013)
|
|
- return 1;
|
|
- ]])],
|
|
- [mysql_has_reconnect="yes"],
|
|
- [mysql_has_reconnect="no"])
|
|
-
|
|
- AC_MSG_RESULT($mysql_has_reconnect)
|
|
-
|
|
- if test "x$mysql_has_reconnect" = "xyes"; then
|
|
- AC_DEFINE([MYSQL_HAS_OPT_RECONNECT],[1],[For MySQL versions 5.0.13 and greater])
|
|
-
|
|
- AC_MSG_CHECKING([for mysql setting of reconnect option before connect bug])
|
|
-
|
|
- AC_RUN_IFELSE(
|
|
- [AC_LANG_PROGRAM(
|
|
- [[
|
|
- #include <mysql.h>
|
|
- ]],
|
|
- [[
|
|
- if (mysql_get_client_version() < 50019)
|
|
- return 1;
|
|
- ]])],
|
|
- [mysql_has_reconnect_bug="no"],
|
|
- [mysql_has_reconnect_bug="yes"])
|
|
-
|
|
- AC_MSG_RESULT($mysql_has_reconnect_bug)
|
|
-
|
|
- if test "x$mysql_has_reconnect_bug" = "xyes"; then
|
|
- AC_DEFINE([MYSQL_HAS_OPT_RECONNECT_BUG],[1],[For MySQL versions 5.0.13 to 5.0.18])
|
|
- fi
|
|
- fi
|
|
- fi
|
|
fi
|
|
|
|
AC_ARG_WITH(odbc,
|