f86a8f3cf8
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24636 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
380 B
Diff
12 lines
380 B
Diff
--- a/config.mk.in
|
|
+++ b/config.mk.in
|
|
@@ -175,7 +175,7 @@ ifeq ($(patsubst linux-gnu%,linux-gnu,$(
|
|
shlibfn = $(1:%=%.$(SHLIB_SUFFIX).$(MAJ).$(MIN))
|
|
shliblefn = $(1:%=%.$(SHLIB_SUFFIX))
|
|
# SHLIB_CLIB = -lc
|
|
- LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB)
|
|
+ LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB) $(LDFLAGS)
|
|
CFLAGS_SHLIB=-fPIC
|
|
endif
|
|
|