813db8bcee
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25350 3c298f89-4303-0410-b956-a3cf2f4a3e73
57 lines
1.8 KiB
Diff
57 lines
1.8 KiB
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -29625,8 +29625,7 @@ echo $ECHO_N "checking for iconv usabili
|
|
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
|
See \`config.log' for more details." >&5
|
|
echo "$as_me: error: cannot run test program while cross compiling
|
|
-See \`config.log' for more details." >&2;}
|
|
- { (exit 1); exit 1; }; }
|
|
+See \`config.log' for more details." >&2;} }
|
|
else
|
|
cat >conftest.$ac_ext <<_ACEOF
|
|
/* confdefs.h. */
|
|
@@ -29683,7 +29682,6 @@ echo "${ECHO_T}no" >&6; }
|
|
echo "${ECHO_T}yes" >&6; }
|
|
fi
|
|
fi
|
|
-
|
|
if test "x$iconv_found" = "xno" ; then
|
|
{ { echo "$as_me:$LINENO: error:
|
|
*** Iconv headers and/or libraries couldn't be found in your system.
|
|
@@ -29692,8 +29690,7 @@ if test "x$iconv_found" = "xno" ; then
|
|
echo "$as_me: error:
|
|
*** Iconv headers and/or libraries couldn't be found in your system.
|
|
*** Try to install them with your software package manager.
|
|
-*** WeeChat can't be built without Iconv support." >&2;}
|
|
- { (exit 1); exit 1; }; }
|
|
+*** WeeChat can't be built without Iconv support." >&2;} }
|
|
fi
|
|
|
|
# ------------------------------------------------------------------------------
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -208,22 +208,8 @@ if test "x$ac_found_iconv_header" = "xye
|
|
if test "x$ac_found_iconv_lib" = "xyes" ; then
|
|
ICONV_LFLAGS="-liconv"
|
|
LIBS="$LIBS $ICONV_LFLAGS"
|
|
+ iconv_found="yes"
|
|
fi
|
|
- AC_MSG_CHECKING(for iconv usability in programs)
|
|
- AC_TRY_RUN([
|
|
- #include <iconv.h>
|
|
- int main(int argc, char **argv) {
|
|
- iconv_t conv = iconv_open("ISO8859-1", "UTF-8");
|
|
- if (conv != (iconv_t) -1) {
|
|
- return 0;
|
|
- }
|
|
- return 1;
|
|
- }],iconv_found="yes")
|
|
- if test "x$iconv_found" = "xno" ; then
|
|
- AC_MSG_RESULT(no)
|
|
- else
|
|
- AC_MSG_RESULT(yes)
|
|
- fi
|
|
fi
|
|
|
|
if test "x$iconv_found" = "xno" ; then
|