![florian](/assets/img/avatar_default.png)
This patch updates haserl to version 0.9.32 and introduces optional lua support See http://haserl.sourceforge.net/manpage.html#lbAM Note: to implement lua support I had to change build process slightly to get rid of host precompilation of lua script. I decided to patch existing Makefile.in instead of patching Makefile.am and regenerating everything from scratch. If this approach is wrong and it's better to patch Makefile.am, please let me know. Signed-off-by: Maxim Storchak <m.storchak@gmail.com> [florian: fix missing quote after source] Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40702 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
445 B
Diff
12 lines
445 B
Diff
--- a/src/h_lua_common.c 2013-09-20 23:35:19.000000000 +0300
|
|
+++ b/src/h_lua_common.c 2014-05-03 19:27:43.000000000 +0300
|
|
@@ -79,7 +79,7 @@
|
|
|
|
/* and load our haserl library */
|
|
if (luaL_loadbuffer
|
|
- (lua_vm, (const char *) &haserl_lualib, sizeof (haserl_lualib),
|
|
+ (lua_vm, (const char *) haserl_lualib, sizeof(haserl_lualib)-1,
|
|
"luascript.lua") || lua_pcall (lua_vm, 0, 0, 0))
|
|
{
|
|
die_with_message (NULL, NULL,
|