4029b82cf8
configure.in contains a test which overrides CFLAGS with CCOPTS when it determines that the compiler is GCC, this breaks build on most platforms where the ABI has to be explicitely specified (e.g: ARM VFP). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39800 3c298f89-4303-0410-b956-a3cf2f4a3e73
20 lines
480 B
Diff
20 lines
480 B
Diff
--- a/configure.in 2014-03-06 14:55:36.627221831 -0800
|
|
+++ b/configure.in 2014-03-06 14:56:48.709112089 -0800
|
|
@@ -53,16 +53,6 @@
|
|
|
|
|
|
dnl
|
|
-dnl Use these compiler flags if we have gcc.
|
|
-dnl
|
|
-if test $ac_cv_prog_gcc = yes; then
|
|
-dnl if test -z $CFLAGS; then
|
|
- CCOPTS='-O2 -funroll-loops -fomit-frame-pointer -Wall'
|
|
- CFLAGS="$CCOPTS"
|
|
-dnl fi
|
|
-fi
|
|
-
|
|
-dnl
|
|
dnl Check for package inclusion/exclusion
|
|
dnl
|
|
AC_ARG_WITH(pf_packet, [ --with-pf_packet=[yes,no] override defaults], \
|