7376de0ff1
Upgrade siproxd, fix init script, link statically with libosip2 (size) and add description. Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> git-svn-id: svn://svn.openwrt.org/openwrt/packages@28029 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
1.0 KiB
Diff
27 lines
1.0 KiB
Diff
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -77,8 +77,8 @@ plugin_regex_la_LDFLAGS = -module -avoid
|
|
# else Cygwin goes beserk when building...)
|
|
#
|
|
sbin_PROGRAMS = siproxd
|
|
-siproxd_LDFLAGS=-export-dynamic
|
|
-siproxd_LDADD = $(LIBLTDL) $(DLOPENPLUGINS)
|
|
+siproxd_LDFLAGS=-export-dynamic -lltdl
|
|
+siproxd_LDADD = $(DLOPENPLUGINS)
|
|
siproxd_SOURCES = siproxd.c proxy.c register.c sock.c utils.c \
|
|
sip_utils.c sip_layer.c log.c readconf.c rtpproxy.c \
|
|
rtpproxy_relay.c accessctl.c route_processing.c \
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -326,8 +326,8 @@ plugin_prefix_la_LDFLAGS = -module -avoi
|
|
#
|
|
plugin_regex_la_SOURCES = plugin_regex.c
|
|
plugin_regex_la_LDFLAGS = -module -avoid-version -shrext '.so'
|
|
-siproxd_LDFLAGS = -export-dynamic
|
|
-siproxd_LDADD = $(LIBLTDL) $(DLOPENPLUGINS)
|
|
+siproxd_LDFLAGS = -export-dynamic -lltdl
|
|
+siproxd_LDADD = $(DLOPENPLUGINS)
|
|
siproxd_SOURCES = siproxd.c proxy.c register.c sock.c utils.c \
|
|
sip_utils.c sip_layer.c log.c readconf.c rtpproxy.c \
|
|
rtpproxy_relay.c accessctl.c route_processing.c \
|