packages/libs/spandsp/patches/100-compile-fixes.patch
jow 5e1b592729 [packages] spandsp: every dead autoconf macro is a good autoconf macro
- Remove AC_FUNC_MALLOC and AC_FUNC_REALLOC, they cause bogus rpl_* symbols
 - Apply autoreconf fixup to get a sane libtool
 - Get rid of rpath-link, this is now uneeded after latest toolchain reworks
 - Bump pkg revision

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29792 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-01-19 02:38:54 +00:00

24 lines
549 B
Diff

--- a/src/spandsp/fast_convert.h
+++ b/src/spandsp/fast_convert.h
@@ -197,7 +197,7 @@ extern "C"
{
return (long int) (x);
}
-#elif defined(__ppc__) || defined(__powerpc__)
+#elif defined(THISISNOTDEFINEDYADDAYADDA)
static __inline__ long int lfastrint(register double x)
{
int res[2];
--- a/configure.ac
+++ b/configure.ac
@@ -152,9 +152,7 @@ AC_ARG_ENABLE(builtin_tiff,
AC_FUNC_ERROR_AT_LINE
AC_FUNC_VPRINTF
-AC_FUNC_MALLOC
AC_FUNC_MEMCMP
-AC_FUNC_REALLOC
AC_FUNC_SELECT_ARGTYPES
AX_C99_FUNC_LRINT