dd34bb19bd
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16574 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
937 B
Diff
25 lines
937 B
Diff
diff -urN mtr-0.75/configure mtr-0.75.new/configure
|
|
--- mtr-0.75/configure 2008-09-19 11:38:58.000000000 +0200
|
|
+++ mtr-0.75.new/configure 2009-06-26 22:41:26.000000000 +0200
|
|
@@ -7956,7 +7956,7 @@
|
|
echo $ECHO_N "checking for C flags to get more warnings... $ECHO_C" >&6; }
|
|
ac_save_CFLAGS="$CFLAGS"
|
|
if test "x$ac_cv_c_compiler_gnu" = "xyes" ; then
|
|
- warning_CFLAGS="-Wall -Wno-pointer-sign"
|
|
+ warning_CFLAGS="-Wall"
|
|
else
|
|
case "$host_os" in
|
|
irix*)
|
|
diff -urN mtr-0.75/configure.in mtr-0.75.new/configure.in
|
|
--- mtr-0.75/configure.in 2008-09-08 09:40:54.000000000 +0200
|
|
+++ mtr-0.75.new/configure.in 2009-06-26 22:41:21.000000000 +0200
|
|
@@ -108,7 +108,7 @@
|
|
ac_save_CFLAGS="$CFLAGS"
|
|
if test "x$ac_cv_c_compiler_gnu" = "xyes" ; then
|
|
dnl gcc is the easiest C compiler
|
|
- warning_CFLAGS="-Wall -Wno-pointer-sign"
|
|
+ warning_CFLAGS="-Wall"
|
|
else
|
|
dnl Vendor supplied C compilers are a bit tricky
|
|
case "$host_os" in
|