packages/net/baresip/patches/101-cross.patch
nico 3711b2a6b3 packages/baresip: update to 0.3.0 (thanks to Alfred E. Heggestad), make it modular, use start-stop-daemon
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28756 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-11-04 22:12:41 +00:00

26 lines
568 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,7 @@ USE_VIDEO := 1
PROJECT := baresip
VERSION := 0.3.0
+ifndef LIBRE_MK
LIBRE_MK := $(shell [ -f ../re/mk/re.mk ] && \
echo "../re/mk/re.mk")
ifeq ($(LIBRE_MK),)
@@ -29,11 +30,14 @@ ifeq ($(LIBRE_MK),)
LIBRE_MK := $(shell [ -f /usr/local/share/re/re.mk ] && \
echo "/usr/local/share/re/re.mk")
endif
+endif
include $(LIBRE_MK)
include mk/modules.mk
+ifndef LIBREM_PATH
LIBREM_PATH := $(shell [ -d ../rem ] && echo "../rem")
+endif
CFLAGS += -I. -Iinclude -I$(LIBRE_INC) -I$(SYSROOT)/include