packages/net/freeswitch/patches/203-src-mod-codecs-mod_silk-Makefile.patch
mazilo fb2956f426 updated to FS git HEAD 5e3a6fc5e6f40be5d68c8b3cfbbfa3227fe06c2f
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35036 3c298f89-4303-0410-b956-a3cf2f4a3e73
2013-01-07 14:25:52 +00:00

16 lines
617 B
Diff

--- a/src/mod/codecs/mod_silk/Makefile
+++ b/src/mod/codecs/mod_silk/Makefile
@@ -1,4 +1,5 @@
BASE=../../../..
+include $(BASE)/build/openwrt_rules.mk
SILK_DIR=$(switch_srcdir)/libs/silk
SILK_BUILDDIR=$(switch_builddir)/libs/silk
LOCAL_CFLAGS=-I$(SILK_DIR)/src -I$(SILK_DIR)/interface
@@ -8,5 +9,5 @@ LOCAL_OBJS=$(BASE)/libs/stfu/stfu.o
include $(BASE)/build/modmake.rules
$(SILK_LA): $(SILK_DIR)/.update
- cd $(SILK_BUILDDIR) && ./configure --disable-shared && make clean && $(MAKE)
+ cd $(SILK_BUILDDIR) && ./configure --host=$(GNU_TARGET_NAME) --disable-shared && make clean && $(MAKE)
$(TOUCH_TARGET)