42801043b2
- php.ini: remove obsolete options - drop patch 'patches/900-prevent_buildconf_force.patch' as php now supports newer autoconf versions 'buildconf --force' can be called after patching the source tree to update build system - cross compiling issue regarding libdl still present, so because of the last point the corresponding patch has to be against configure.in but configure - update timezone patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@32872 3c298f89-4303-0410-b956-a3cf2f4a3e73
15 lines
370 B
Diff
15 lines
370 B
Diff
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
|
|
PHP_CHECK_FUNC(gethostbyaddr, nsl)
|
|
PHP_CHECK_FUNC(yp_get_default_domain, nsl)
|
|
|
|
-PHP_CHECK_FUNC(dlopen, dl)
|
|
+PHP_ADD_LIBRARY(dl)
|
|
+PHP_DEF_HAVE(dlopen)
|
|
+PHP_DEF_HAVE(libdl)
|
|
+ac_cv_func_dlopen=yes
|
|
if test "$ac_cv_func_dlopen" = "yes"; then
|
|
AC_DEFINE(HAVE_LIBDL, 1, [ ])
|
|
fi
|