f802a822a2
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17605 3c298f89-4303-0410-b956-a3cf2f4a3e73
21 lines
562 B
Diff
21 lines
562 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -32,7 +32,7 @@ install: ptunnel
|
|
install ./ptunnel.8 $(mandir)/ptunnel.8
|
|
|
|
ptunnel: $(PT_OBJS)
|
|
- $(CC) -o $@ $^ $(LDOPTS) `[ -e /usr/include/selinux/selinux.h ] && echo -lselinux`
|
|
+ $(CC) -o $@ $^ $(LDOPTS)
|
|
|
|
ptunnel.exe: $(WIN32_PT_OBJS)
|
|
$(CC) -o $@ $^ $(WIN32_LDOPTS)
|
|
@@ -47,7 +47,7 @@ depend: .depend
|
|
$(CC) $(CFLAGS) -MM *.c > $@
|
|
|
|
%.o:%.c
|
|
- $(CC) $(CFLAGS) `[ -e /usr/include/selinux/selinux.h ] && echo -DHAVE_SELINUX` -c -o $@ $<
|
|
+ $(CC) $(CFLAGS) -c -o $@ $<
|
|
|
|
%.obj:%.c
|
|
$(WIN32_CC) $(WIN32_CFLAGS) -c -o $@ $<
|