packages/net/mdnsresponder/patches/002-uclibc.patch
florian ff2ac2bebe [package] update mdnsresponder to 214.3.2 (#8083)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23754 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-10-31 23:30:01 +00:00

22 lines
722 B
Diff

diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSResponder-214.3.2/mDNSPosix/Makefile
--- mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile 2010-10-15 08:38:44.798283212 -0500
+++ mDNSResponder-214.3.2/mDNSPosix/Makefile 2010-10-15 08:48:27.334503432 -0500
@@ -361,12 +361,16 @@
endif
else
-ifeq ($(os),linux)
+# Any variant containing linux:
+ifeq ($(findstring linux,$(os)),linux)
CFLAGS_OS = -DNOT_HAVE_SA_LEN -DUSES_NETLINK -DHAVE_LINUX -DTARGET_OS_LINUX
FLEXFLAGS_OS = -l
JAVACFLAGS_OS += -I$(JDK)/include/linux
+# uClibc does not provide NSS, do not compile nss_mdns:
+ifneq ($(os),linux-uclibc)
OPTIONALTARG = nss_mdns
OPTINSTALL = InstalledNSS
+endif
else
ifeq ($(os),netbsd)