9e9d3900d4
Update ZNC to newest version 1.0 * Update config format to reflect new config format and allow multiple networks per user. * Update init script to create a 1.0 compatible config. * Add new modules introduced in 1.0, remove dropped ones. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@34659 3c298f89-4303-0410-b956-a3cf2f4a3e73
39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
From 94aff4c3389111fc85054eb06b40bea26a216d0c Mon Sep 17 00:00:00 2001
|
|
From: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
|
|
Date: Sat, 16 Apr 2011 05:51:04 +0200
|
|
Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
|
|
|
|
---
|
|
Makefile.in | 2 +-
|
|
modules/Makefile.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -96,7 +96,7 @@ clean:
|
|
distclean: clean
|
|
rm -rf $(DISTCLEAN)
|
|
|
|
-src/%.o: src/%.cpp Makefile
|
|
+src/%.o: src/%.cpp
|
|
@mkdir -p .depend src
|
|
$(E) Building core object $*...
|
|
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
|
|
--- a/modules/Makefile.in
|
|
+++ b/modules/Makefile.in
|
|
@@ -114,12 +114,12 @@ install_datadir:
|
|
clean:
|
|
rm -rf $(CLEAN)
|
|
|
|
-%.o: %.cpp Makefile
|
|
+%.o: %.cpp
|
|
@mkdir -p .depend
|
|
$(E) Building module $(notdir $(basename $@))...
|
|
$(Q)$(CXX) $(MODFLAGS) -c -o $@ $< $($(notdir $(basename $@))CXXFLAGS) -MD -MF .depend/$(notdir $@).dep
|
|
|
|
-%.so: %.o Makefile
|
|
+%.so: %.o
|
|
$(E) Linking module $(notdir $(basename $@))...
|
|
$(Q)$(CXX) $(MODFLAGS) $(LDFLAGS) $(MODLINK) -o $@ $< $($(notdir $(basename $@))LDFLAGS) $(LIBS)
|
|
|