eb3a4ae50a
on platforms with VFP/hardfloat ld fails with: empcd uses VFP register arguments, empcd.o does not empcd uses VFP register arguments, keyeventtable.o does not empcd uses VFP register arguments, support/mpc-0.12.2/src/libmpdclient.o does not append to CFLAGS instead of overwrite Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40787 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
341 B
Diff
12 lines
341 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -17,7 +17,7 @@ DEPS = Makefile
|
|
OBJS = empcd.o keyeventtable.o support/mpc-0.12.2/src/libmpdclient.o
|
|
WARNS = -W -Wall -pedantic -Wno-format -Wno-unused -Wno-long-long
|
|
EXTRA = -g3
|
|
-CFLAGS = $(WARNS) $(EXTRA) -D_GNU_SOURCE
|
|
+CFLAGS += $(WARNS) $(EXTRA) -D_GNU_SOURCE
|
|
LDFLAGS =
|
|
CC = gcc
|
|
RM = rm
|