099c9d1440
- Relocate libraries and shared files to /usr/lib/crtmpserver and /usr/share/crtmpserver - Add missing defines from CMake to make - Set new CCOMPILER and CXXCOMPILER variables as well git-svn-id: svn://svn.openwrt.org/openwrt/packages@29785 3c298f89-4303-0410-b956-a3cf2f4a3e73
16 lines
771 B
Diff
16 lines
771 B
Diff
Index: crtmpserver-r692/builders/make/linux.mk
|
|
===================================================================
|
|
--- crtmpserver-r692.orig/builders/make/linux.mk
|
|
+++ crtmpserver-r692/builders/make/linux.mk
|
|
@@ -31,8 +31,8 @@ OPTIMIZATIONS = -O3
|
|
COMPILE_FLAGS = $(FPIC) $(OPTIMIZATIONS) $(CFLAGS)
|
|
|
|
#linking flags
|
|
-dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,"\$$ORIGIN"
|
|
-dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,"\$$ORIGIN"
|
|
+dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,/usr/lib/crtmpserver
|
|
+dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,/usr/lib/crtmpserver
|
|
|
|
#compile switches
|
|
PLATFORM_DEFINES = \
|