90f5b33dc5
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6540 3c298f89-4303-0410-b956-a3cf2f4a3e73
49 lines
1.0 KiB
Diff
49 lines
1.0 KiB
Diff
--- asterisk-1.2.14/codecs/gsm/Makefile.orig 2007-02-21 23:03:07.000000000 +0100
|
|
+++ asterisk-1.2.14/codecs/gsm/Makefile 2007-02-21 23:03:40.000000000 +0100
|
|
@@ -241,6 +241,10 @@
|
|
ifneq ($(shell uname -m),armv4l)
|
|
ifneq ($(shell uname -m),sparc64)
|
|
ifneq (${PROC},arm)
|
|
+ifneq (${PROC},armeb)
|
|
+ifneq (${PROC},mipsel)
|
|
+ifneq (${PROC},mips)
|
|
+ifneq (${PROC},powerpc)
|
|
ifneq ($(shell uname -m), parisc)
|
|
ifneq ($(shell uname -m),s390)
|
|
GSM_SOURCES+= $(SRC)/k6opt.s
|
|
@@ -255,6 +258,10 @@
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
|
|
TOAST_SOURCES = $(SRC)/toast.c \
|
|
$(SRC)/toast_lin.c \
|
|
@@ -308,6 +314,11 @@
|
|
ifneq ($(shell uname -m), alpha)
|
|
ifneq ($(shell uname -m), sparc64)
|
|
ifneq ($(shell uname -m), armv4l)
|
|
+ifneq (${PROC}, arm)
|
|
+ifneq (${PROC}, armeb)
|
|
+ifneq (${PROC}, mipsel)
|
|
+ifneq (${PROC}, mips)
|
|
+ifneq (${PROC}, powerpc)
|
|
ifneq ($(shell uname -m), parisc)
|
|
ifneq ($(shell uname -m),s390)
|
|
GSM_OBJECTS+= $(SRC)/k6opt.o
|
|
@@ -321,6 +331,11 @@
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
+endif
|
|
|
|
TOAST_OBJECTS = $(SRC)/toast.o \
|
|
$(SRC)/toast_lin.o \
|