b94f02fe5f
* move all python packages to lang section * add a python-package.mk rules file sourced by all python packages for PyPackage/* defs * introduce a new way of specifying files to be packaged (experimental) * add missing svn:properties git-svn-id: svn://svn.openwrt.org/openwrt/packages@8639 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
457 B
Diff
12 lines
457 B
Diff
--- pyevent-0.3-old/event.pyx 2005-09-11 22:16:15.000000000 -0500
|
|
+++ pyevent-0.3/event.pyx 2007-06-12 11:28:33.000000000 -0500
|
|
@@ -259,7 +259,7 @@
|
|
global __event_exc
|
|
event_dispatch()
|
|
if __event_exc:
|
|
- raise __event_exc[0], __event_exc[1], __event_exc[2]
|
|
+ raise OSError, "%s [%s]" % (__event_exc[0], __event_exc[1]), __event_exc[2]
|
|
|
|
def loop(nonblock=False):
|
|
"""Dispatch all pending events on queue in a single pass."""
|