822a7a1f72
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13822 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
772 B
Diff
23 lines
772 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -24519,7 +24519,7 @@ fi
|
|
{ echo "$as_me:$LINENO: result: $WITH_PCRE" >&5
|
|
echo "${ECHO_T}$WITH_PCRE" >&6; }
|
|
|
|
-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
|
|
+if test "$WITH_PCRE" != "no"; then
|
|
# Extract the first word of "pcre-config", so it can be a program name with args.
|
|
set dummy pcre-config; ac_word=$2
|
|
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -252,7 +252,7 @@ AC_ARG_WITH(pcre, AC_HELP_STRING([--with
|
|
[WITH_PCRE=$withval],[WITH_PCRE=yes])
|
|
AC_MSG_RESULT([$WITH_PCRE])
|
|
|
|
-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
|
|
+if test "$WITH_PCRE" != "no"; then
|
|
AC_PATH_PROG(PCRECONFIG, pcre-config)
|
|
|
|
if test x"$PCRECONFIG" != x; then
|