7ad5b78d24
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8739 3c298f89-4303-0410-b956-a3cf2f4a3e73
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
diff -Nru asterisk-1.2.24.org/channels/Makefile asterisk-1.2.24/channels/Makefile
|
|
--- asterisk-1.2.24.org/channels/h323/Makefile 2007-03-06 16:17:16.000000000 +0100
|
|
+++ asterisk-1.2.24/channels/h323/Makefile 2007-09-04 18:37:58.000000000 +0200
|
|
@@ -21,9 +21,8 @@
|
|
OPENH323DIR=$(HOME)/openh323
|
|
endif
|
|
|
|
-clean:
|
|
- rm -f *.so *.o .depend
|
|
-
|
|
+include $(OPENH323DIR)/openh323u.mak
|
|
+
|
|
$(SOURCES):: $(SOURCES:.cxx=.cpp)
|
|
ln -f $< $@
|
|
|
|
@@ -31,7 +30,6 @@
|
|
touch $(SOURCES)
|
|
|
|
libchanh323.a: $(OBJS)
|
|
- include $(OPENH323DIR)/openh323u.mak
|
|
ar crv $@ $(OBJS)
|
|
|
|
Makefile.ast: FORCE
|
|
diff -Nru asterisk-1.2.14.org/channels/Makefile asterisk-1.2.14/channels/Makefile
|
|
--- asterisk-1.2.14.org/channels/Makefile 2006-08-17 23:57:19.000000000 +0200
|
|
+++ asterisk-1.2.14/channels/Makefile 2006-12-27 09:22:09.000000000 +0100
|
|
@@ -15,6 +15,7 @@
|
|
#
|
|
|
|
CHANNEL_LIBS=chan_sip.so chan_agent.so chan_mgcp.so chan_iax2.so chan_local.so chan_skinny.so chan_features.so
|
|
+CXXLIBS=-lstdc++
|
|
|
|
ifneq (${OSARCH},CYGWIN)
|
|
# if you really, really want to use these drivers, uncomment the line below
|
|
@@ -228,7 +229,7 @@
|
|
|
|
ifeq (${OSARCH},Linux)
|
|
chan_h323.so: chan_h323.o h323/libchanh323.a h323/Makefile.ast
|
|
- $(CC) $(SOLINK) $(H323LDFLAGS) -o $@ $< h323/libchanh323.a $(H323LDLIBS) -lstdc++
|
|
+ $(CC) $(SOLINK) $(H323LDFLAGS) -o $@ $< h323/libchanh323.a $(H323LDLIBS) $(CXXLIBS)
|
|
else
|
|
chan_h323.so: chan_h323.o h323/libchanh323.a
|
|
$(CC) $(SOLINK) -o $@ $< h323/libchanh323.a $(CHANH323LIB) -L$(PWLIBDIR)/lib $(PTLIB) -L$(OPENH323DIR)/lib $(H323LIB) -L/usr/lib -lcrypto -lssl -lexpat
|