packages/utils/usbmuxd/patches/001-disable_libusbmuxd_tools.patch
swalker 5e94aa477b [packages] libusbmuxd: add separate libusbmuxd & tools package that was split from usbmuxd
[packages] usbmuxd: disable building & packaging the bundled libusbmuxd & tools

Signed-off-by: Stephen Walker <stephendwalker+openwrt@gmail.com>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40705 3c298f89-4303-0410-b956-a3cf2f4a3e73
2014-05-05 23:10:44 +00:00

33 lines
1.1 KiB
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,19 +64,12 @@ endif()
add_definitions(-Wall)
-add_subdirectory (libusbmuxd)
if (WITH_USBMUXD)
add_subdirectory (daemon)
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_subdirectory (udev)
endif()
endif()
-add_subdirectory (tools)
-
-# pkg-config
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/libusbmuxd.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc")
-# install pkg-config file
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc" DESTINATION lib${LIB_SUFFIX}/pkgconfig/)
# add uninstall target
configure_file("${CMAKE_SOURCE_DIR}/Modules/cmake_uninstall.cmake.in" "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake" IMMEDIATE @ONLY)
--- a/daemon/CMakeLists.txt
+++ b/daemon/CMakeLists.txt
@@ -8,7 +8,6 @@ if(HAVE_PLIST)
endif()
include_directories (${CMAKE_SOURCE_DIR}/common)
include_directories (${CMAKE_SOURCE_DIR}/daemon)
-include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
add_definitions(-DUSBMUXD_DAEMON -DUSBMUXD_VERSION="${USBMUXD_VERSION}")
add_executable(usbmuxd main.c usb-linux.c log.c ${CMAKE_SOURCE_DIR}/common/utils.c device.c client.c)