2657effd05
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5911 3c298f89-4303-0410-b956-a3cf2f4a3e73
64 lines
1.9 KiB
Diff
64 lines
1.9 KiB
Diff
diff -urN lua-5.1.1/Makefile lua-5.1.1.new/Makefile
|
|
--- lua-5.1.1/Makefile 2006-06-02 12:53:38.000000000 +0200
|
|
+++ lua-5.1.1.new/Makefile 2006-12-28 01:40:18.000000000 +0100
|
|
@@ -42,7 +42,7 @@
|
|
# What to install.
|
|
TO_BIN= lua luac
|
|
TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
|
|
-TO_LIB= liblua.a
|
|
+TO_LIB= liblua.a liblualib.a liblua.so liblua.so.$R liblualib.so.$R
|
|
TO_MAN= lua.1 luac.1
|
|
|
|
# Lua version and release.
|
|
diff -urN lua-5.1.1/src/Makefile lua-5.1.1.new/src/Makefile
|
|
--- lua-5.1.1/src/Makefile 2006-03-22 01:41:49.000000000 +0100
|
|
+++ lua-5.1.1.new/src/Makefile 2006-12-28 01:39:29.000000000 +0100
|
|
@@ -23,6 +23,7 @@
|
|
PLATS= aix ansi bsd generic linux macosx mingw posix solaris
|
|
|
|
LUA_A= liblua.a
|
|
+LUA_SO= liblua.so
|
|
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
|
|
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
|
|
lundump.o lvm.o lzio.o
|
|
@@ -36,8 +37,9 @@
|
|
LUAC_O= luac.o print.o
|
|
|
|
ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
|
|
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
|
|
+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
|
|
ALL_A= $(LUA_A)
|
|
+ALL_SO= $(LUA_SO)
|
|
|
|
default: $(PLAT)
|
|
|
|
@@ -47,10 +49,19 @@
|
|
|
|
a: $(ALL_A)
|
|
|
|
+so: $(ALL_SO)
|
|
+
|
|
$(LUA_A): $(CORE_O) $(LIB_O)
|
|
$(AR) $@ $?
|
|
+ $(AR) liblualib.a $?
|
|
$(RANLIB) $@
|
|
+ $(RANLIB) liblualib.a
|
|
|
|
+$(LUA_SO): $(CORE_O) $(LIB_O)
|
|
+ $(LD) -o $@.$(PKG_VERSION) -shared -soname="$@.$(PKG_VERSION)" $?
|
|
+ $(LD) -o liblualib.so.$(PKG_VERSION) -shared -soname="liblualib.so.$(PKG_VERSION)" $?
|
|
+ ln -fs $@.$(PKG_VERSION) $@; ln -fs liblualib.so.$(PKG_VERSION) liblualib.so
|
|
+
|
|
$(LUA_T): $(LUA_O) $(LUA_A)
|
|
$(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
|
|
|
|
@@ -92,7 +103,7 @@
|
|
$(MAKE) all MYCFLAGS=
|
|
|
|
linux:
|
|
- $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
|
|
+ $(MAKE) all MYCFLAGS+=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
|
|
|
|
macosx:
|
|
$(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
|