![jow](/assets/img/avatar_default.png)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@36404 3c298f89-4303-0410-b956-a3cf2f4a3e73
44 lines
895 B
Diff
44 lines
895 B
Diff
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -763,40 +763,6 @@ esac
|
|
AC_MSG_RESULT(no)
|
|
fi
|
|
|
|
- AC_CHECK_FUNCS(EVP_sha256 EVP_sha384 EVP_sha512)
|
|
-
|
|
- AC_MSG_CHECKING(for OpenSSL ECDSA support)
|
|
- have_ecdsa=""
|
|
- AC_TRY_RUN([
|
|
-#include <stdio.h>
|
|
-#include <openssl/ecdsa.h>
|
|
-#include <openssl/objects.h>
|
|
-int main() {
|
|
- EC_KEY *ec256, *ec384;
|
|
-
|
|
-#if !defined(HAVE_EVP_SHA256) || !defined(HAVE_EVP_SHA384)
|
|
- return (1);
|
|
-#endif
|
|
- ec256 = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1);
|
|
- ec384 = EC_KEY_new_by_curve_name(NID_secp384r1);
|
|
- if (ec256 == NULL || ec384 == NULL)
|
|
- return (2);
|
|
- return (0);
|
|
-}
|
|
-],
|
|
- [AC_MSG_RESULT(yes)
|
|
- have_ecdsa="yes"],
|
|
- [AC_MSG_RESULT(no)
|
|
- have_ecdsa="no"])
|
|
- case $have_ecdsa in
|
|
- yes)
|
|
- OPENSSL_ECDSA="yes"
|
|
- AC_DEFINE(HAVE_OPENSSL_ECDSA)
|
|
- ;;
|
|
- *)
|
|
- ;;
|
|
- esac
|
|
-
|
|
AC_MSG_CHECKING(for OpenSSL GOST support)
|
|
have_gost=""
|
|
AC_TRY_RUN([
|