packages/net/freeswitch/patches/002-Makefile.am.patch
mazilo 8e1f61e69f git update
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28682 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-10-30 17:47:10 +00:00

68 lines
2.1 KiB
Diff

--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,7 @@
+BASE=.
+
+include $(BASE)/build/openwrt_rules.mk
+
EXTRA_DIST =
SUBDIRS = . src
AUTOMAKE_OPTS = foreign
@@ -61,7 +65,7 @@ cd-moh-install: uhd-moh-install sounds-m
# (1) if the variable is set in `config.status', edit `config.status'
# (which will cause the Makefiles to be regenerated when you run `make');
# (2) otherwise, pass the desired values on the `make' command line.
-all-recursive: libfreeswitch.la
+all-recursive: spandsp-reconf libfreeswitch.la
clean-recusive: clean_core
install-recursive: install-libLTLIBRARIES install-binPROGRAMS
$(RECURSIVE_TARGETS):
@@ -299,7 +303,7 @@ endif
##
fs_encode_SOURCES = src/fs_encode.c
fs_encode_CFLAGS = $(AM_CFLAGS)
-fs_encode_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
+fs_encode_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
fs_encode_LDADD = libfreeswitch.la -lcrypt -lrt
##
@@ -307,7 +311,7 @@ fs_encode_LDADD = libfreeswitch.la -lcry
##
tone2wav_SOURCES = src/tone2wav.c
tone2wav_CFLAGS = $(AM_CFLAGS)
-tone2wav_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
+tone2wav_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
tone2wav_LDADD = libfreeswitch.la -lcrypt -lrt
##
@@ -586,10 +590,13 @@ speex-reconf:
tiff-reconf:
cd libs/tiff-3.8.2 && autoreconf -fi
- cd libs/tiff-3.8.2 && sh ./configure.gnu
+ cd libs/tiff-3.8.2 && sh ./configure.gnu --host=$(GNU_TARGET_NAME)
cd libs/spandsp && autoreconf -fi
- cd libs/spandsp && sh ./configure.gnu
- make mod_voipcodecs-clean
+ cd libs/spandsp && sh ./configure.gnu --host=$(GNU_TARGET_NAME) --prefix=$(prefix)
+ cd libs/tiff-3.8.2 && $(MAKE)
+
+spandsp-reconf: tiff-reconf
+ cd libs/spandsp && $(MAKE)
python-reconf:
rm -f src/mod/languages/mod_python/Makefile
@@ -612,12 +619,6 @@ iks-reconf:
cd libs/iksemel && sh ./configure.gnu --prefix=$(prefix)
$(MAKE) mod_dingaling-clean
-spandsp-reconf:
- cd libs/spandsp && $(MAKE) clean || echo
- cd libs/spandsp && autoreconf -fi
- cd libs/spandsp && sh ./configure.gnu --prefix=$(prefix)
- cd libs/spandsp && $(MAKE)
-
sofia-reconf:
cd libs/sofia-sip && sh ./autogen.sh
cd libs/sofia-sip && $(MAKE) clean