d1a7b7bc4c
Patch from Oliver Smith git-svn-id: svn://svn.openwrt.org/openwrt/packages@31185 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
894 B
Diff
29 lines
894 B
Diff
--- a/bind/Makefile 2011-11-28 23:08:15.000000000 +0000
|
|
+++ b/bind/Makefile 2011-12-17 16:27:20.784433502 +0000
|
|
@@ -49,13 +49,16 @@
|
|
|
|
# Build the export libraries
|
|
@echo Building BIND Export libraries - this takes some time.
|
|
+ @(cd ${bindsrcdir}/lib/export/dns ; \
|
|
+ echo building gen using ${BUILD_CC} in `pwd` ; \
|
|
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen)
|
|
@(cd ${bindsrcdir}/lib/export ; \
|
|
echo building in `pwd` ; \
|
|
MAKE=${GMAKE} ${GMAKE} > ${binddir}/build.log)
|
|
|
|
@echo Installing BIND Export libraries to ${binddir}.
|
|
@(cd ${bindsrcdir}/lib/export ; \
|
|
- MAKE=${GMAKE} ${GMAKE} install > ${binddir}/install.log)
|
|
+ $(MAKE) DESTDIR="" install > ${binddir}/install.log)
|
|
|
|
clean:
|
|
@echo Cleaning BIND export library.
|
|
@@ -64,6 +67,7 @@
|
|
|
|
# Include the following so that this Makefile is happy when the parent
|
|
# tries to use them.
|
|
+install-exec:
|
|
|
|
distdir:
|
|
|