![juhosg](/assets/img/avatar_default.png)
Version 2.0 of xtables-addons dropped support for all kernels older than 3.7. So we still need to build v1.x for older kernels. Keep a separate patches directory for it, with almost all the same patches for now. We can easily drop the 1.x build once we have more than two platforms running 3.7. Signed-off-by: David Woodhouse <David.Woodhouse@intel.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@34921 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
892 B
Diff
23 lines
892 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -11780,7 +11780,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
|
if test -n "$kbuilddir"; then
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
|
|
$as_echo_n "checking kernel version that we will build against... " >&6; }
|
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
|
kmajor="${krel%%[^0-9]*}";
|
|
kmajor="$(($kmajor+0))";
|
|
krel="${krel:${#kmajor}}";
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
|
|
|
if test -n "$kbuilddir"; then
|
|
AC_MSG_CHECKING([kernel version that we will build against])
|
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
|
kmajor="${krel%%[[^0-9]]*}";
|
|
kmajor="$(($kmajor+0))";
|
|
krel="${krel:${#kmajor}}";
|