packages/libs/zaptel-1.4.x/patches/380-use_cross_ar.patch
nbd f1b112b632 zaptel-1.4.x: unbreak kernel module build, use cross-ar and cross-ranlib to fix further build issues
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32425 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-06-18 15:06:33 +00:00

24 lines
553 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -30,6 +30,9 @@ else
UNAME_M:=$(DEB_HOST_GNU_TYPE)
endif
+AR ?= ar
+RANLIB ?= ranlib
+
# If you want to build for a kernel other than the current kernel, set KVERS
ifndef KVERS
KVERS:=$(shell uname -r)
@@ -352,8 +355,8 @@ ztspeed: CFLAGS=
sethdlc-new: CFLAGS+=-I$(KINCLUDES)
$(LTZ_A): $(LTZ_A_OBJS)
- ar rcs $@ $^
- ranlib $@
+ $(AR) rcs $@ $^
+ $(RANLIB) $@
$(LTZ_SO): $(LTZ_SO_OBJS)
$(CC) $(CFLAGS) -shared -Wl,-soname,$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER) -o $@ $^ $(LDFLAGS) $(LDLIBS) -lm