b797a23e77
This updates packages/utils/mtd-utils and includes all patches from tools/mtd-utils, so the two may eventually be merged. I also added 150-fix_ubi-utils_static.patch which is a hack needed to include libcrc32.o in the static binaries. Having them static makes sense as only ubiformat is required on the target. [juhosg: - add build-time dependency on util-linux - allow to specify dependency for each subpackage - update ubifs optional lzo patch - add more patches] Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@31913 3c298f89-4303-0410-b956-a3cf2f4a3e73
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
--- a/ubi-utils/Makefile
|
|
+++ b/ubi-utils/Makefile
|
|
@@ -22,7 +22,7 @@ $(TARGETS): $(addprefix $(BUILDDIR)/,\
|
|
# $(CC) $(CFLAGS) $(filter %.o, $^) -L. -lubi -o $@
|
|
|
|
$(BUILDDIR)/ubicrc32: $(addprefix $(BUILDDIR)/,\
|
|
- ubicrc32.o)
|
|
+ ../lib/libcrc32.o ubicrc32.o)
|
|
# $(CC) $(CFLAGS) -o $@ $^
|
|
|
|
$(BUILDDIR)/ubinize: $(addprefix $(BUILDDIR)/,\
|
|
@@ -30,16 +30,17 @@ $(BUILDDIR)/ubinize: $(addprefix $(BUILD
|
|
# $(CC) $(CFLAGS) $(filter %.o, $^) -L. -liniparser -lubigen -o $@
|
|
|
|
$(BUILDDIR)/mtdinfo: $(addprefix $(BUILDDIR)/,\
|
|
- libubigen.a ubiutils-common.o)
|
|
+ ../lib/libmtd.o ../lib/libmtd_legacy.o libubigen.a ubiutils-common.o)
|
|
# $(CC) $(CFLAGS) $(filter %.o, $^) -L. -lmtd -lubigen -o $@
|
|
|
|
$(BUILDDIR)/ubiformat: $(addprefix $(BUILDDIR)/,\
|
|
- ubiformat.o ubiutils-common.o libscan.a libubi.a libubigen.a)
|
|
+ ../lib/libmtd.o ../lib/libmtd_legacy.o ubiformat.o ubiutils-common.o libscan.a libubi.a libubigen.a)
|
|
# $(CC) $(CFLAGS) $(filter %.o, $^) -L. -lmtd -lscan -lubi -lubigen -o $@
|
|
|
|
$(BUILDDIR)/libubi.a: $(BUILDDIR)/libubi.o
|
|
|
|
-$(BUILDDIR)/libubigen.a: $(BUILDDIR)/libubigen.o
|
|
+$(BUILDDIR)/libubigen.a: $(addprefix $(BUILDDIR)/,\
|
|
+ ../lib/libcrc32.o libubigen.o)
|
|
|
|
$(BUILDDIR)/libiniparser.a: $(addprefix $(BUILDDIR)/,\
|
|
libiniparser.o dictionary.o)
|