fadc28ab79
Do not link against libevent if present on your target. That lib is completely different from the libevent in rp-pppoe. The lib is part of the dependencies, so no -L and -l are necessary anyway. Signed-off-by: Nils Rennebarth <nils.rennebarth@teldat.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39517 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
452 B
Diff
12 lines
452 B
Diff
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -71,7 +71,7 @@ pppoe-sniff: pppoe-sniff.o if.o common.o
|
|
@CC@ -o $@ $^ $(LDFLAGS)
|
|
|
|
pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@
|
|
- @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS) -Llibevent -levent
|
|
+ @CC@ -o $@ @RDYNAMIC@ $^ $(LDFLAGS) $(PPPOE_SERVER_LIBS)
|
|
|
|
pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o
|
|
@CC@ -o $@ $^ $(LDFLAGS)
|