packages/admin/zabbix/patches/001-cross_compile.patch
hauke 0d416a1cc0 Zabbix: update to 2.2.1
With this new version of zabbix we do not need
uname and hostname anymore, see
https://svn.zabbix.com/browse/ZBX-5616
Only compile tested for now

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@39489 3c298f89-4303-0410-b956-a3cf2f4a3e73
2014-02-05 21:27:13 +00:00

30 lines
700 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -804,25 +804,8 @@ dnl ************************************
dnl Check for %qu format (FreeBSD 4.x)
dnl FreeBSD 4.x does not support %llu
-AC_MSG_CHECKING(for long long format)
-AC_TRY_RUN(
-[
-#include <sys/types.h>
-int main()
-{
- uint64_t i;
-
- sscanf("200000000010020", "%qu", &i);
-
- if (i == 200000000010020) return 0;
- else return -1;
-}
-],
-AC_DEFINE(HAVE_LONG_LONG_QU, 1 ,[Define to 1 if format '%qu' exists.])
-AC_MSG_RESULT(yes),
-AC_MSG_RESULT(no))
-
dnl option -rdynamic is needed for readable backtraces
+
AC_MSG_CHECKING(for -rdynamic linking option)
saved_LDFLAGS="$LDFLAGS"
LDFLAGS="-rdynamic $LDFLAGS"