packages/net/xl2tpd/patches/100-makefile_opt_flags.patch
thepeople 9cb6f12ea8 this patch updates xl2tpd to 1.2.5. From the changelog:
* Fix initscript for
https://bugzilla.redhat.com/show_bug.cgi%3Fid%3D247100
* Fix for two Windows machines behind the same NAT with the same
 number of l2tp connection attempts since boot [Shinichi Furuso]

Changes in this patch:

* use PKG_INSTALL:=1
* use standard config file names like in other major distributions
* new patch to disable building pfc (which was not installed anyway),
 removes dependency to libpcap
* include a commented sample config file
* use INSTALL_CONF instead of INSTALL_DATA + chmod 0600

-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20276 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-18 16:01:35 +00:00

13 lines
486 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -90,7 +90,8 @@ OSFLAGS?= -DLINUX -I$(KERNELSRC)/include
FFLAGS= -DIP_ALLOCATION
-CFLAGS+= $(DFLAGS) -O2 -fno-builtin -Wall -DSANITY $(OSFLAGS) $(FFLAGS)
+OFLAGS=-O2
+CFLAGS+= $(DFLAGS) $(OFLAGS) -fno-builtin -Wall -DSANITY $(OSFLAGS) $(FFLAGS)
HDRS=l2tp.h avp.h misc.h control.h call.h scheduler.h file.h aaa.h md5.h
OBJS=xl2tpd.o pty.o misc.o control.o avp.o call.o network.o avpsend.o scheduler.o file.o aaa.o md5.o
SRCS=${OBJS:.o=.c} ${HDRS}